Hi everyone, I'm just getting started.  I've gathered all the tools, read Fletcher's book about 6 times (so great), and read quite a lot of these posts (also great).  I've decided to build a 17x54.  Went to the lumber dealer in town, and decided i'm definitely going to use the Hydrotek BS 1088 6mm for sides, and 12mm for floor.  I'm going to use Mahogany for the Stem.  I'm planning to use Port Orford Cedar for the frames, and was thinking i'd match that with White Oak for the rails/chines.  I hope to have the boat for the rest of my life, and while i want it to be the most beautiful boat ever built, I truly want to use materials that will last and be effective.  So, first question... Instead of White Oak, anyone ever use Port Orford for rails?  It seems like the color would be similar to White Oak, but i wonder about durability as a rail.  appreciate any insight you might have.

Views: 9311

Reply to This

Replies to This Discussion

Also got the oarlock blocks installed.  Starting with white oak rather than uhmw.  But man, I had a cool moment. While I was ensuring the proper positioning, I sat in the rower's seat with my oarlocks in, my rafting oars with blades removed, but it felt so amazing sitting in the rower's seat with oars imagining rowing.  I can already tell its going to be so great.

LAUNCH DAY IS IN SIGHT!!
I'm excited for you.

Looking great!

Rick

That is one lovely boat you put together. Excellent work! 

Stainless Steel chine cap protection.  Not cheap.  I had to learn how to drill and counter sink Stainless Steel. 

Yesterday was a big day for me!  

Launched my boat at Hayden Bridge on the McKenzie.  Which is the site of my first memory in a drift boat, fly fishing while my dad was rowing in 1979 when I was about 6 years old.

this is a picture of me in a state of well being, about 1 minute after launching.

Hell yeah! Good job Dusty!

This is the take out at Armitage.

I need some advice.  I've only been on the river 6 times w/ my boat and just discovered this discoloration around one of the nails used to secure the rub strip.  I'm guessing water is getting in  behind the rub strip and making its way up the nail hole from behind.  Although I did encapsulate the rub strip w/epoxy before attaching it, I didn't put 5200 or lifecaulk or anything like that between the rub strip and the hull, which appears to be a big mistake.  I assume i need to remove the rub strip asap to make sure water's not getting into the main hull.  I don't know exactly how to remove the strip, but figured I'd cut off the nail heads and just pull it off and cross my fingers about the hull.  Any thoughts/ input are appreciated.

RSS

© 2022   Created by Randy Dersham.   Powered by

Badges  |  Report an Issue  |  Terms of Service